Nem indul el az ÁNYK, pedig nemrég még működött

Az ÁNYK (Általános Nyomtatványkitöltő Program) zökkenőmentesen működött Ubuntu linux alatt, aztán egyik nap nem indult el, hiába kattintgattam rá. Többféle hibalehetőség kizárása után arra jutottam, hogy itt lehet az eb elhantolva: “Az ÁNYK a v2.67.0 verziótól csak a Java 1.8 verziójával működik!”. Azaz telepíteni kell a legfrissebb Java programot az Ubuntura!

Más operációs rendszerek alatt működő ÁNYK a cikknek nem témája.

Ha tehát valaki azt tapasztalja, hogy nem indul el az ÁNYK, pedig nemrég még működött, annak az (is) lehet az oka, hogy telepítette a Nyomtatványkitöltő Program olyan verzióját, mely a “régi” Java környezet alatt nem futtatható. Miért változott meg a működése egyik napról a másikra a szoftverünknek? Azért, mert a programon belül nem csak új nyomtatvány telepítése lehetséges, hanem az egész ÁNYK is frissíthető a legújabb verzióra.

Hogy valóban a Java környezet okozza a problémát, arról könnyen meggyőződhetünk.

Ellenőrizzük le az Ubuntu rendszerünkre telepített Java verziót. Ehhez nyissunk egy terminálablakot a [CTRL]+[ALT]+T billenytűk egyidejű lenyomásával, majd gépeljük be a

version -java

parancsot és üssünk egy [ENTER]-t. Ha a build nem úgy kezdődik, hogy 1.8…. (hanem mondjuk 1.7.0….)
akkor frissítenünk kell a Java keretprogramot ahhoz, hogy az Általános Nyomtatványkitöltő Program zökkenőmentesen működhessen.

A terminál ablakban tehetjük ezt meg a legegyszerűbben, az alábbi parancsok begépelésével:

$ sudo add-apt-repository ppa:webupd8team/java
$ sudo apt-get update
$ sudo apt-get install oracle-java8-installer

Ha a gépünk kéri a jelszavunkat, akkor gépeljük be, majd ha lefutott a frissítés, nyissuk meg az ÁNYK programot.

Ha sikerült, a SZERVIZ menüben a NÉVJEGY alatt megnézhetjük, hogy a gépünkre telepített ÁNYK-nak mi a verziószáma:

Általános Nyomtatványkitöltő Program (ÁNYK)

A NAV weboldalán mindig tudjuk ellenőrizni, az aktuális rendszerkövetelményeket.

Ha tetszik, jelezd nekünk:

Vélemény, hozzászólás?

Scroll to top